Converting geo-files to geojson

In this tutorial, you will learn how to convert any type of geographic vector file into the explorer.land's native geo-format geojson. The following proposed conversion procedure uses the free and open-source software QGIS.

Note: The following explanation is based on a QGIS verion > 3.0 running in a Microsoft Windows environment, but the procedure should be similar for previous QGIS versions and/or other OS environments.

Getting started: downloading & installing QGIS.

Shouldn't you have QGIS installed on your PC, then open the QGIS project site on your browser https://qgis.org/en/site/. Navigate to their download page and select the installation suite suitable for your operating system. Install the software on your device and start it.

Loading vector files into QGIS

There are two ways to open vector files in QGIS: 1) Grabbing and dropping the files from your desktop environment directly into the QGIS software's windows or 2) opening them using the software's menu interface.

Variant 1: Drag-n-drop
This variant is by far the simplest. Just select the geo-file on your desktop environment you want to convert, and drag it into the QGIS window. In the majority of the cases, QGIS will automatically recognize the format of your geo-file. You should now see your geographical data in the 'map' area of the software.

Variant 2: Opening the files via menu interface
To open your vector file in QGIS go to Layer > Add Layer > Add Vector Layer.

In the new window, use the Source field to select the file you want to open (1) and click on the Add button (2). You should now see your geographic data as a new layer in QGIS. Click on the Close button to close the window.

Exporting the vector data as geojson

Note: Before proceeding, make sure you have the Layers pane activated in QGIS' user interface. If not, active it by going to View > Panels and select Layers.

To export your data right click on the respective layer entry in the Layers pane. In the context menu select Export and Save Feature As...

A new window will open.

  1. In the Format field select geojson from the drop down list.
  2. Select where you want to save the file by clicking on the following symbol:
  3. Select the correct referencing system (CRS) which has to be EPSG:4326 - WGS84! Any other CRS will not work with explorer.land

Click on OK to export the geojson file.

You can now import it into explorer.land.


Creating a Site

Select Sites from the content menu on the right of your project overview. On the top …

Mass upload

It is possible to create several Sites at once by uploading a vector file containing …

Introduction
User accounts
Projects
Sites
Posts
Sponsors & Sponsorships
Organizations
Embedding
Story Mapping App
References